Руководство Бизнес-аналитика

Page tree

Руководство Бизнес-аналитика. Платформа Web-BPM 2.0

Skip to end of metadata
Go to start of metadata

Установка программ

Инструкции для Windows, на других платформах установите соответствующие программы самостоятельно.

  1. Установка Slack
  2. Менеджер пакетов Chocolatey
    1. Инструкция
    2. Если при установке возникли проблемы с правами доступа, нужно сначала выполнить в консоли команду Set-ExecutionPolicy -ExecutionPolicy ALLSIGNED
  3. Git
    1. Запустить cmd консоль с правами администратора
    2. выполнить команду choco install git
  4. UI для гит (Source Tree)
    1. Скачать и установить английскую версию Source Tree.
  5. JDK 1.8 x64
    1. Скачать с сайта Oracle 64 битную версию
    2. Установить в каталог без пробелов, например C:\programs
  6. Maven
    1. Запустить cmd консоль с правами администратора
    2. выполнить команду choco install maven
    3. если предыдущая команда упала, то выполнить choco install maven --version 3.3.9 (Последнюю версию можно посмотреть здесь в разделе Version History)
  7. PostgreSQL 9.5 (опционально)
    1. Скачать с сайта Postgres.
    2. Установить
  8. Intellij Idea
    1. Скачать и установить с сайта JetBrains. Разработчикам нужна Ultimate, QA достаточно Community.
  9. Настройка VPN (не обязательный пункт)
    1. Взять доступ VPN  у руководителя, либо администратора.
    2. Windows. Прописать доступы в параметрах, поставить игнорирование автоматических маршрутов
    3. Mint, Ubuntu 16.05. Прописать доступы в параметрах, поставить игнорирование автоматических маршрутов
    4. Ubuntu 18.04+. Отсутствует настройка игнорирования автоматических маршрутов. Для корректной работы VPN/глобальная сеть установить forticlientsslvpn и настроить доступы в ней.

Настройка программ

Настройка Slack

  1. Отправить архитектору проекта свой email

Настройка Git

  1. Установка имени и email
    Для SourceTree:
    1. Запускаем SourceTree, открываем настройки
    2. Убеждаемся что на вкладке General включен параметр Allow SourceTree to modify your global Git and Mercurial config files
    3. На вкладке General заполняем поля Default user informationFull Name и Email address
    Если вы используете консоль или другой git клиент воспроизуйтесь инструкцией по ссылке https://git-scm.com/book/en/v2/Getting-Started-First-Time-Git-Setup
  2. Генерация ssh ключей (Windows)
    1. Запускаем git bash. Для этого в консоли выполняем команду "C:\Program Files\Git\bin\bash" (Если гит установлен в другом месте, то поправить путь).
    2. В git bash выполняем команду ssh-keygen -t rsa (ВО ИЗБЕЖАНИЕ ПРОБЛЕМ НАЗВАНИЕ ФАЙЛА СЕРТИФИКАТА НЕ МЕНЯЕМ И ПАРОЛЬ НЕ ЗАДАЕМ). 
    3. Предыдущая команда по умолчанию создает ssh ключ в домашнем каталоге пользователя в папке .ssh. В ней лежит файл с расширением .pub – это публичный ключ используемый для доступа в git.
  3. Настройка ssh в SourceTree
    1. В SourceTree открываем настройки, вкладка General
    2. Ставим параметр SSH Client в OpenSSH
  4. Получение прав на внутренний git репозиторий
    1. Публичный ssh ключ отправляем архитектору проекта
  5. Получение прав на github
    1. отправляем архитектору проекта свой github account name или email используемый на github
    2. на почту должно придти письмо от github с приглашением, принимаем его.
  6. Получение прав на Bitbucket
    1. отправляем архитектору проекта свой Bitbucket account name или email используемый на Bitbucket
  7. Добавление git в переменную PATH (Windows)
    1. Если git установлен через chocolatey, то уже выполнено при установке.

Настройка Java

  1. Установка переменной среды JAVA_HOME

Настройка Maven

  1. Установка переменной среды M2_HOME
    1. Если maven установлен через chocolatey, то уже выполнено при установке. (Windows)
  2.  Авторизация в Nexus

Чекаут проекта

  1. Скачать проект (например через File /New / Project from Version Control в идее): git@10.10.31.70:/webbpm-platform
  2. Скачать тестовый проект (его надо будет открыть в приложение после его запуска через идею):  git@10.10.31.70:/webbpm-test-project
  3. Скачать и установить node.js. В проекте используется 14 версия

Настройка Idea

Тестировщик может пользоваться этим

  1. Плагины (Только для разработчиков)
    1. Дополнительно нужно включить JavaFX
  2. Настройка Code Style
    1. Скачиваем settings.jar отсюда и следуем инструкции с той же страницы.
  3. Настройка кодировки (Нужно проверить для каждого проекта)
    1. В настройках идеи находим Editor -> File Encodings и выставляем параметры IDE Encoding, Project Encoding, Default encoding for properties files в UTF-8.
    2. Там же, рядом с Default encoding for properties files, ставим галку Transparent native-to-ascii conversion

       

  4. Настройка хедера новых файлов
    1. В настройках идеи находим Editor -> File and Code Templates, открываем вкладку Includes, настраиваем File Header:

      File Header
      /**
       * @author ${USER}
       */
       

      Если системный пользователь называется не совсем хорошо, то его можно задать следующим образом:

      File Header
      #set( $USER = "Tim Urmancheev" )
      /**
       * @author ${USER}
       */
  5. Настройка Maven (Нужно проверить для каждого проекта)

    1. В настройках идеи находим Build, Execution, Deployment -> Build Tools -> Maven

    2. Включаем параметр Print exception stack traces

    3. Ставим параметр Threads в 2C

    4. Меняем Maven home directory с bundled на установленный через chocolatey

  6. Настройка версии java
    1. В настройках проекта вкладка SDKs – добавляем jdk для 1.8
    2. В настройках проекта вкладка Project – ставим Project SDK на только что созданный
    3. В настройках проекта вкладка Project – ставим Project language level на SDK default
  7. JavaFX (Только для разработчиков)
    1. Скачиваем и устанавливаем JavaFX Scene Builder
    2. В настройках идеи находим Languages & Frameworks -> JavaFX и прописываем путь до Scene Builder
  8. Run Configuration для студии (проект webbpm-platform)
    1. Создаем Application run configuration
    2. Ставим Main class – ru.cg.webbpm.studio.distribution.launcher.Main
    3. Копируем Working directory в Program arguments и добавляем туда путь /studio/application/launcher/target/ide/
    4. В Use classpath of module выбираем launcher
    5. Из списка Before Launch удаляем Make (Build, если имеется)
    6. Опционально можно настроить чтобы перед каждым запуском автоматом собиралась студия, тогда следующий пункт не актуален.
      Для этого в Before Launch добавляем Run Maven Goal и в Command line ставим clean package -T 2C 
    7. Для включения поддержки студии CEF-браузера, необходимо запустить проект со следующим значением VM Options: 

      -Xmx2g -Djavax.servlet.request.encoding=UTF-8 -Dfile.encoding=UTF-8 -Djavafx.embed.singleThread=true
      Для студии с версией ниже 2.86 необходимо еще указать параметр -Djava.library.path=с:\temp\libs\
    8. Чтобы не было проблем с кириллическими символами в именах файлов, в т.ч. в пути до папки пользователя, необходимо добавить переменную окружения с кодировкой для maven:

Настройка уведомлений Teamcity

  1. Войдите в teamcity
  2. Нажмите на имя учётки (см. 1)
  3. Укажите email address (см. 2)
  4. Узнайте имя пользователя в git командой 

    git config user.name
  5. Введите имя пользователя на вкладке VSC Username (см. 3)

также возможно будут полезны ссылки:



Настройка сервера приложений

  1. На текущий момент лучше установить тестовый сервер приложение с помощью установщика https://repo.micord.ru/service/rest/v1/search/assets/download?repository=libs-releases-local&maven.groupId=ru.cg.webbpm.studio.application&maven.artifactId=installer&maven.classifier&sort=version

There is no content with the specified labels